Repository navigation
chore(deps): bump gpustack-runner and resolve dependabot alerts - #35
Conversation
- bump gpustack-runner to >=0.1.32.post1 in pyproject.toml - override filelock to 3.20.3 on Python <3.11 and >=4.2.1 on Python >=3.11 - upgrade gpustack-runner, filelock, virtualenv, and setuptools in uv.lock Task 1 of dependabot-alerts. Signed-off-by: thxCode <thxcode0824@gmail.com>
There was a problem hiding this comment.
Code Review
This pull request updates the gpustack-runner dependency to >=0.1.32.post1 and configures uv dependency overrides for filelock to target version 3.20.3 on Python versions below 3.11 and >=4.2.1 on Python 3.11 and above. The uv.lock file has been updated accordingly, which also includes minor version bumps for setuptools and virtualenv. No review comments were provided, and I have no feedback to offer on these changes.
There was a problem hiding this comment.
🔵 Needs a closer look
The Python 3.10 override selects filelock below virtualenv’s declared minimum, so runtime compatibility needs confirmation beyond the reported resolution dry run.
No open issues 🎉
What changed in this PR
Updates GPUStack Runtime’s runner dependency and refreshes development dependencies to address the reported Dependabot alerts while retaining Python 3.10 support.
Changes:
- Raises the
gpustack-runnerminimum to0.1.32.post1. - Updates locked
virtualenvandsetuptoolsversions. - Adds Python-version-specific
filelockoverrides and corresponding lockfile entries.
| File | Description |
|---|---|
uv.lock |
Records updated dependencies and Python-specific filelock resolutions. |
pyproject.toml |
Raises the runner minimum and adds filelock overrides. |
Review effort: Balanced
Bump the
gpustack-runnerfloor to>=0.1.32.post1and regenerateuv.lockto resolve all 15 open Dependabot security alerts across transitivedevdependencies:gpustack-runner:0.1.31->0.1.32.post1virtualenv:21.14.7->21.15.0(GHSA-c978-59m8-c77v,GHSA-43mp-35q3-x3fq,GHSA-cw65-gx24-rc82,GHSA-558c-9hv2-4prj,GHSA-hhxq-47xx-j5xx,GHSA-qmx5-4p3x-wvqf,GHSA-6w3r-xr62-4xcp,GHSA-fc2g-4w5p-6whm,GHSA-394h-qwmc-48pf,GHSA-494p-63j8-28p3,GHSA-cx28-75q4-x26q)setuptools:84.0.0->84.2.1(GHSA-xmj3-9gf7-h52w)filelock:3.32.5->3.20.3(python_full_version < '3.11') and4.2.4(python_full_version >= '3.11') (GHSA-v4x8-3wr5-3wq8,GHSA-567q-5qvw-pf92,GHSA-9vhv-jxww-xfm5)Root Cause &
filelockOverridefilelock >= 4.1.1dropped Python 3.10 support (requires-python = ">=3.11"), whilepyproject.tomlsupports>=3.10andvirtualenv >= 21.14.9declaresfilelock<5,>=3.24.2; python_version >= "3.10". Without an override,uv locksplitsfilelockinto4.1.0forpython_full_version < '3.11'and4.2.4forpython_full_version >= '3.11', leaving4.1.0inside the vulnerable>= 3.20.4, <= 4.2.0and>= 4.1.0, <= 4.2.0advisory ranges.Neither
virtualenvnorpython-discoveryusesReadWriteLock(both import onlyFileLockandTimeout). Adding[tool.uv] override-dependenciespinsfilelock==3.20.3on Python< 3.11(the release outside both< 3.20.3and>= 3.20.4, <= 4.2.0) andfilelock>=4.2.1(4.2.4) on Python>= 3.11.Validation
uv.lockare clear of vulnerable ranges.uv sync --python 3.10 --all-packages --dry-runresolves cleanly.make lintclean;make test— 715 passed, 20 skipped.