Skip to content

Setup failing between steps 3 and 4 on /db #354

Description

@juekr

Platform: Debian GNU/Linux 11
Server type: NGINX
PHP version: 8.2

Like others in this forum, my installation/configuration stops between steps 3 and 4 with a 403 on a URL ending with /db. Unlike others I have a nginx setup and after reading about the others' experiences, I could imagine that there is something failing with the htaccess or apache vhost configurations. But I have no idea how to tackle or even debug them with a nginx webserver (came preinstalled with my hoster). Any ideas on what to do to solve or further track down the problem?

Activity

JulianPrieber commented on Mar 8, 2023

@JulianPrieber
Member

I thought we fixed this issue a while ago.

You can skip the installation with example.com/skip.

juekr commented on Mar 8, 2023

@juekr
Author

/skip gives me a 404 as well – did I install an old version by accident?

JulianPrieber commented on Mar 8, 2023

@JulianPrieber
Member

Do other routes still work?

juekr commented on Mar 8, 2023

@juekr
Author

Like?

JulianPrieber commented on Mar 8, 2023

@JulianPrieber
Member

Like just example.com or example.com/mysql-test.

JulianPrieber commented on Mar 8, 2023

@JulianPrieber
Member

During the installation, the app is set up to redirect all unknown routes to the home/installer page.
This means during setup, 404s shouldn't even be possible.

It will probably be best to reinstall the app.

The thing that confuses me is all that the /db route does is redirect you to the next step in the installer:

        if($request->database == 'MySQL'){
            return redirect(url('?mysql'));
        }else{
            return redirect(url('?4'));
        }

juekr commented on Mar 8, 2023

@juekr
Author

/ works and starts the config process again, /mysql-test produces another 404.

Did I maybe miss a step in the installation? Isn't it just "Download and extract the zip file"? Is there more to it?

JulianPrieber commented on Mar 8, 2023

@JulianPrieber
Member

On NGINX, you'll have to configure your block first for the app to function properly, but essentially yes.
https://laravel.com/docs/9.x/deployment#nginx
https://docs.littlelink-custom.com/getting-started/other-webservers/

One thing that's also important is that PHP is able to read and write to all the files, but in most cases this is possible by default.

JulianPrieber commented on Mar 8, 2023

@JulianPrieber
Member

It's nothing really different from installing WordPress.

jmdv-es commented on Mar 14, 2023

@jmdv-es

Hi @JulianPrieber, maybe I can share some light:

this error described by @juekr is also happening to me. It's happening while deploying the files in an IONOS web server.

But, using an OVH web server, the applications install without problem.

crackscout123 commented on Mar 20, 2023

@crackscout123

I got the same issue, but fixed it by enabling .thacces but then encounterd another error the installer is looking for two file which dont exsist called "INSTALLING" and "INSTALLERLOCK" here is the error code:
https://flareapp.io/share/W7zRk3k7#F55

crackscout123 commented on Mar 26, 2023

@crackscout123

Im going to reinstall it on a different server cause I changed my provider. I'll poste an update when im done.

DrMxrcy commented on Mar 29, 2023

@DrMxrcy

I am getting the same error on my docker install. I can install with a local IP, but the setup redirects the /db to HTTP and 404s

JulianPrieber commented on Mar 29, 2023

@JulianPrieber
Member

@DrMxrcy

I am getting the same error on my docker install. I can install with a local IP, but the setup redirects the /db to HTTP and 404s

If you're accessing the docker directly over the IP and port, then it works?

crackscout123 commented on Mar 30, 2023

@crackscout123

Im going to reinstall it on a different server cause I changed my provider. I'll poste an update when im done.

It wont work, i gave up

JulianPrieber commented on Mar 30, 2023

@JulianPrieber
Member

For everyone still wondering what's causing this:

This is most likely a Vhost issue in your setup or reverse proxy. You need to set up your app to redirect everything to HTTPS.
Cloudflare has an option to do this for you, with no additional setup. We have documentation on this for NGINX reverse proxy or web. Everything else should be documented here or online somewhere.

If anyone is having this issue with docker, set up your instance using the IP and port directly without a reverse proxy. Then on the config page, enable force HTTPS.

For anyone else, just skip the setup and you should be fine. On the setup page, visit /skip this generates a default admin profile, and you can use the app like normal. Then on the config page, enable force HTTPS.

You can log in with:
admin@admin.com
12345678

locked and limited conversation to collaborators on Mar 30, 2023
converted this issue into a discussion #383 on Mar 30, 2023
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions