Repository navigation
chore: upgrade next.js and its packages to a release with the security fix (#5002) - #5007
Merged
Merged
Conversation
Contributor
There was a problem hiding this comment.
🟢 Approval recommended
The dependency updates are consistent across the manifest and lockfile, with no identified blocking issues.
No open issues 🎉
What changed in this PR
Updates the data browser’s Next.js dependencies to address the security upgrade requested in #5002, without changing application code.
Changes:
- Raises Next.js, MDX, and Next.js ESLint package minimums to
^16.4.3. - Updates locked Next.js packages and platform binaries to 16.4.3, plus security-related updates to
fast-uriandzod.
| File | Description |
|---|---|
package.json |
Raises the minimum versions of four Next.js-related dependencies. |
package-lock.json |
Records updated dependency versions, integrity hashes, and matching Next.js binaries. |
Review effort: Balanced
frano-m
marked this pull request as ready for review
October 26, 2026 10:23
5 tasks
…y fix (#5002) raise next, @next/mdx, @next/eslint-plugin-next and eslint-config-next to ^16.4.3, which fixes GHSA-2464-fhr4-w9xw, GHSA-673q-mjm6-r5xr and GHSA-p3m5-59mp-jv5r. also run npm audit fix (no force), which bumps fast-uri to 3.1.9 and zod to 4.6.7. Co-Authored-By: Claude Opus 5.5 (1M context) <noreply@anthropic.com> Co-authored-by: cc-claude-tools <cc-claude-tools@clevercanary.com>
frano-m
force-pushed
the
frano-m/5002-next-security-upgrade
branch
from
October 27, 2026 06:43
4d3c5cf to
29640b8
Compare
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Closes #5002
What changed
next,@next/mdx,@next/eslint-plugin-nextandeslint-config-next:^16→^16.4.3inpackage.json;package-lock.jsonresolves all four (plus@next/envand the@next/swc-*binaries) to 16.4.3.npm audit fix(no--force):fast-uri3.1.8 → 3.1.9 andzod→ 4.6.7, clearing their moderate / high advisories.Why
next16.0.0–16.4.0 is affected by GHSA-2464-fhr4-w9xw (critical), GHSA-673q-mjm6-r5xr (critical) and GHSA-p3m5-59mp-jv5r (high). On 16.4.0,next devprints a security notice and then exits with code 1, which is the "exited before serving a page" behaviour in the issue. On 16.4.3 all four site configs start normally.Exposure of the deployed sites:
next.config.mjssetsoutput: "export"(andimages.unoptimized: true), so the deployed sites are static files with no Next server at runtime. The Image Optimization API,use cachefunctions and Server Actions the advisories describe are not running in production; the exposure was local dev and build machines.Assumptions I made
package.jsonfloor to^16.4.3so the manifest itself cannot resolve to a vulnerable version.next-env.d.ts(16.4.3 adds aroot-params.d.tsimport, in an order that failsprettier-plugin-organize-imports) andtsconfig.json(16.4.0 does this too) during build/dev. Both are left as onmain; expect them to show as modified after a local build.csv-parse,esbuildand@digitak/esrunneed breaking upgrades (npm audit fix --force), so they are out of scope.next ^16),@mui/material-nextjs(^16),next-sitemap(any) andnext-mdx-remote6 (no Next peer) all accept 16.4.3;next-authis not installed in this repo.main/ 16.4.0 or caused by the backend):/data/consortia/CARD) throwTypeError: _jsx is not a functionfromnext-mdx-remote. Production builds render all 170 pages fine.lm2catalog (onlydcp3,dcp3-it)..github/dependabot.ymlpoints at the removed/spadirectory, so the root manifest gets no Dependabot version PRs — tracked in Investigate dependabot config pointing at removed /spa directory #5006.How to verify
git checkout frano-m/5002-next-security-upgrade && npm cinpm ls next→ a singlenext@16.4.3, deduped under findable-ui,@mui/material-nextjsandnext-sitemap.npm audit→ nonext,fast-uriorzodentries.npm run dev:anvil-cmg,dev:hca-dcp,dev:anvil-catalog,dev:lungmap: the banner readsNext.js 16.4.3, there is no "affected by a known security vulnerability" notice, and the server stays up.http://localhost:3000/datasetslists datasets; open one (e.g. ANVIL_1000G_2019_Dev) for the detail page; Sign In shows the Google sign-in card.http://localhost:3000/projectslists projects; open one for the detail page; Sign In shows the sign-in card.http://localhost:3000/data/consortialists consortia. Detail pages hit the_jsxdev error above (same onmain); sign-in is disabled for this site.lm2404 above (backend); sign-in is disabled for this site.npm run lint(0 errors),npx tsc --noEmit,npx jest, and the production buildsbuild-dev:anvil-catalog,build:anvil-cmg,build-ma-dev:hca-dcp,build-dev:lungmapall pass.Definition of done from #5002:
nextand the@next/*/eslint-config-nextpackages are on a release that fixes the advisories (16.4.2 or later), andpackage-lock.jsonis updated. → steps 1–2next devstarts without the security notice for every site config (anvil-catalog, anvil-cmg, hca-dcp, lungmap). → step 3main.🤖 Generated with Claude Code
🐦 Built with cc-claude-tools