From 05b9e020e51ee34a684133494fdf3d1063700381 Mon Sep 17 00:00:00 2001 From: Jesse Rosenstock Date: Wed, 21 Oct 2026 16:21:56 +0200 Subject: [PATCH] Cargo.toml: Bump rust-version to 1.88 The declared rust-version of 1.70 has been out of date for a while. Several dependencies already require a newer compiler, so no toolchain older than 1.88 can build the project today: * `sysinfo` 0.38 (every 0.38.x release) declares rust-version 1.88. * `uutests` 0.12 (dev-dependency) declares rust-version 1.88. * `rand` 0.10, `phf` 0.14, `md-5` 0.11 and the locked `clap` 4.6 declare 1.85, and `lsipc`/`lslocks` use edition 2024, which also needs 1.85. `uucore` 0.7 and later also declare rust-version 1.88, so this is a prerequisite for upgrading `uucore` from 0.2.2. The field documents the real minimum and is what the MSRV-aware resolver and clippy's MSRV-dependent lints (e.g. `incompatible_msrv`) use, so it should match what the dependencies need. Note that the checked-in Cargo.lock currently has `uuid` 1.28, which declares rust-version 1.89. A 1.88 toolchain needs `uuid` <= 1.26.1; the MSRV-aware resolver (`CARGO_RESOLVER_INCOMPATIBLE_RUST_VERSIONS=fallback cargo update`) picks that version. CI builds with the latest stable toolchain and has no MSRV job, so no workflow change is needed. --- Cargo.toml | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Cargo.toml b/Cargo.toml index 96bc8b19..70109762 100644 --- a/Cargo.toml +++ b/Cargo.toml @@ -16,7 +16,7 @@ repository = "https://github.com/uutils/util-linux" readme = "README.md" keywords = ["util-linux", "uutils", "cross-platform", "cli", "utility"] categories = ["command-line-utilities"] -rust-version = "1.70.0" +rust-version = "1.88.0" edition = "2021" build = "build.rs"